summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Silverstone <dsilvers@digital-scurf.org>2021-04-24 15:57:00 +0100
committerDaniel Silverstone <dsilvers@digital-scurf.org>2021-05-01 13:15:41 +0100
commit2d1db750d50b6b68ca31d7ade1bba0316b792aa8 (patch)
treeaab1541f3f26ceeaa130151bb8c10036c8f89ec9 /Cargo.toml
parent1315a361f8479d29d20128a35665aab2b84e13ed (diff)
downloadsubplot-2d1db750d50b6b68ca31d7ade1bba0316b792aa8.tar.gz
pandoc_ast: Support multiple versions of pandoc_ast
In order to cope with multiple versions of Pandoc, we need to support various pandoc_ast versions. This patch introduces support for both 0.8 and 0.7, defaulting to the older 0.7. If you use Subplot on a system with a much newer pandoc, then switch to the 0.8 variant to cope. Signed-off-by: Daniel Silverstone <dsilvers@digital-scurf.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 7 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7085773..b4d473d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -16,8 +16,14 @@ repository = "https://gitlab.com/larswirzenius/subplot"
[workspace]
members = [ "subplotlib", "subplotlib-derive" ]
+[features]
+default = ["ast_07"]
+ast_07 = ["pandoc_ast_07"]
+ast_08 = ["pandoc_ast_08"]
+
[dependencies]
-pandoc_ast = "0.8"
+pandoc_ast_07 = { package = "pandoc_ast", version = "0.7", optional = true }
+pandoc_ast_08 = { package = "pandoc_ast", version = "0.8", optional = true }
pandoc = "0.8.0"
structopt = "0.3"
base64 = "0.13.0"