summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2021-09-14 14:14:38 +0300
committerLars Wirzenius <liw@liw.fi>2021-09-16 16:40:18 +0300
commit458525d21c9960d98fa932be06cf133cd910ce7b (patch)
tree08f3d913e388c5870231b757f64ed0fe157ba105 /Cargo.toml
parent9198b69c561e582704dbd99000d59e474c406a67 (diff)
downloadsubplot-458525d21c9960d98fa932be06cf133cd910ce7b.tar.gz
feat! parse Markdown input with pull-cmark instead of Pandoc
This is a first step towards being able to use Subplot codegen from a project's build.rs, and with only pure-Rust build dependencies. Replace Pandoc for parsing Markdown input with pulldown-cmark. This is mostly a drop-in replacement, but not entirely. The YAML parsing is more strict now. Note that this is a breaking change. Some subplots that used to work, and still work with docgen, no longer work with the new parser. Major differences are: * Only specific fields are supported. All the Markdown files in the Subplot source tree work. If anything else is needed, and it likely is, the new parser needs to be extended. * The bindings, functions, classes, and bibliography fields MUST be lists of strings. A single string value will no longer work. Sponsored-by: pep.foundation
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 451c378..5753f63 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -46,6 +46,7 @@ git-testament = "0.2"
tracing = "0.1"
tracing-appender = "0.1"
tracing-subscriber = "0.2"
+pulldown-cmark = "0.8.0"
[dependencies.tera]
version = "1"
@@ -53,4 +54,4 @@ default-features = true
[build-dependencies]
walkdir = "2"
-anyhow = "1" \ No newline at end of file
+anyhow = "1"