summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2021-10-05 12:02:56 +0300
committerLars Wirzenius <liw@liw.fi>2021-10-13 10:04:59 +0300
commit5855c963b8c1e1748f50301ddcc21a923be60240 (patch)
tree2b53f37057da8b93e9b67250de9104d7c0883795 /Cargo.toml
parent2459137129c64e02a2948f6c5f9e17bf56742c64 (diff)
downloadsubplot-5855c963b8c1e1748f50301ddcc21a923be60240.tar.gz
feat: add crate subplot-build for using Subplot from build.rs
Make it easy to generate test code from a subplot in another project's `build.rs` script. Move the code to load documents and generate test code from src/bin/subplot.rs and src/bin/cli/mod.rs to src/doc.rs so it can be used without using the subplot executable. Make the add_search_path function public so it can be used outside its module. The subplot executable arranged for the directory where the markdown input file resides to be added to the search path via another way. Sponsored-by: pep.foundation
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5753f63..2823b1b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,7 +15,7 @@ repository = "https://gitlab.com/subplot/subplot"
default-run = "subplot"
[workspace]
-members = [ "subplotlib", "subplotlib-derive" ]
+members = [ "subplotlib", "subplotlib-derive", "subplot-build" ]
[features]
default = ["ast_07"]