summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Silverstone <dsilvers@digital-scurf.org>2022-03-12 15:51:11 +0000
committerDaniel Silverstone <dsilvers@digital-scurf.org>2022-03-12 15:51:11 +0000
commit82d8edc0b037c83833753d41a40cc9c754345ede (patch)
tree91236c51b172b6f17d0d4d7a55ee6dadad5ebd5a /Cargo.toml
parent8023eb8f80884cd81449d70ec271d7bc4400450f (diff)
downloadsubplot-82d8edc0b037c83833753d41a40cc9c754345ede.tar.gz
(chore): Update various crates a bit more
Signed-off-by: Daniel Silverstone <dsilvers@digital-scurf.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c40ac3f..ea435b5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,7 +15,7 @@ repository = "https://gitlab.com/subplot/subplot"
default-run = "subplot"
[workspace]
-members = [ "subplotlib", "subplotlib-derive", "subplot-build", "examples/seq" ]
+members = ["subplotlib", "subplotlib-derive", "subplot-build", "examples/seq"]
[features]
default = ["ast_07"]
@@ -32,11 +32,11 @@ pandoc = "0.8.0"
pandoc_ast_07 = { package = "pandoc_ast", version = "0.7", optional = true }
pandoc_ast_08 = { package = "pandoc_ast", version = "0.8", optional = true }
pikchr = "0.1"
-pulldown-cmark = "0.8.0"
+pulldown-cmark = "0.9.0"
regex = "1"
-roadmap = "0.3"
+roadmap = "0.4"
serde = { version = "1.0.101", features = ["derive"] }
-serde-aux = "2.1"
+serde-aux = "3.0"
serde_json = "1.0"
serde_yaml = "0.8.11"
structopt = "0.3"
@@ -44,8 +44,8 @@ tempfile = "3.1.0"
tempfile-fast = "0.3.1"
thiserror = "1"
tracing = "0.1"
-tracing-appender = "0.1"
-tracing-subscriber = "0.2"
+tracing-appender = "0.2"
+tracing-subscriber = { version = "0.3", features = ["env-filter", "json"] }
time = { version = "0.3", features = ["formatting", "macros"] }
[dependencies.tera]