summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2022-03-24 11:38:08 +0200
committerLars Wirzenius <liw@liw.fi>2022-03-24 11:46:52 +0200
commit84a07a5b77575a981c86b7e9a3e697428d4a94d2 (patch)
treef3c9d3a89e605fa140748c34544473e9a7556d92 /Cargo.toml
parentbcc64e41ca47b1578b3d697d02cdff0ca1e0daa3 (diff)
downloadsubplot-84a07a5b77575a981c86b7e9a3e697428d4a94d2.tar.gz
feat! change logging to use log/env_logger instead of tracing
We don't use async in Subplot, and the mental overhead of learning tracing and the code overhead to add support for logging custom values (implementing the Value trait for Subplot internal types) does not seem worthwhile. Sponsored-by: author
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ea435b5..7a1a297 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -28,10 +28,12 @@ base64 = "0.13.0"
file_diff = "1"
git-testament = "0.2"
lazy_static = "1"
+log = "0.4.16"
pandoc = "0.8.0"
pandoc_ast_07 = { package = "pandoc_ast", version = "0.7", optional = true }
pandoc_ast_08 = { package = "pandoc_ast", version = "0.8", optional = true }
pikchr = "0.1"
+pretty_env_logger = "0.4.0"
pulldown-cmark = "0.9.0"
regex = "1"
roadmap = "0.4"
@@ -43,10 +45,8 @@ structopt = "0.3"
tempfile = "3.1.0"
tempfile-fast = "0.3.1"
thiserror = "1"
-tracing = "0.1"
-tracing-appender = "0.2"
-tracing-subscriber = { version = "0.3", features = ["env-filter", "json"] }
time = { version = "0.3", features = ["formatting", "macros"] }
+env_logger = "0.9.0"
[dependencies.tera]
version = "1"