summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2022-05-14 13:33:05 +0000
committerLars Wirzenius <liw@liw.fi>2022-05-14 13:33:05 +0000
commitaaca2d2797631b310c8990257cff9b01c658478c (patch)
tree80ef2b8fa1fa50548cf73b2abdc16736c7ae9ef1 /Cargo.toml
parent27b617cbaa9e6d4fb58a0b971b428a05da8ec5d9 (diff)
parent37d304a6f95b8488d45f9adcc0c8742d3b121d2f (diff)
downloadsubplot-aaca2d2797631b310c8990257cff9b01c658478c.tar.gz
Merge branch 'clap3-derive' into 'main'
(cli): Change from structopt to clap3-derive Closes #284 See merge request subplot/subplot!276
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 523794a..7e07c83 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -25,6 +25,7 @@ ast_08 = ["pandoc_ast_08"]
[dependencies]
anyhow = "1"
base64 = "0.13.0"
+clap = { version = "3", features = ["derive", "env"] }
file_diff = "1"
git-testament = "0.2"
lazy_static = "1"
@@ -41,7 +42,6 @@ serde = { version = "1.0.101", features = ["derive"] }
serde-aux = { version = "3.0", default-features = false }
serde_json = "1.0"
serde_yaml = "0.8.11"
-structopt = "0.3"
tempfile = "3.1.0"
tempfile-fast = "0.3.1"
thiserror = "1"