summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2022-01-29 13:01:17 +0200
committerLars Wirzenius <liw@liw.fi>2022-02-02 16:26:50 +0200
commitc41710433925fbf945417c42f03d1f08b98fe4fa (patch)
treeab67b54409a1fc3b0a326cb319b440a8cf2f4fba /Cargo.toml
parent16a97d690a9e6f523f6390acc3813e1fb55b44a1 (diff)
downloadsubplot-c41710433925fbf945417c42f03d1f08b98fe4fa.tar.gz
chore: rewrite use of chorno crate to use just time crate
Also, sort the dependency list in Cargo.toml so it's tidy. Sponsored-by: author
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml30
1 files changed, 15 insertions, 15 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 216b15c..8854ddd 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -23,30 +23,30 @@ ast_07 = ["pandoc_ast_07"]
ast_08 = ["pandoc_ast_08"]
[dependencies]
+anyhow = "1"
+base64 = "0.13.0"
+file_diff = "1"
+git-testament = "0.2"
+lazy_static = "1"
+pandoc = "0.8.0"
pandoc_ast_07 = { package = "pandoc_ast", version = "0.7", optional = true }
pandoc_ast_08 = { package = "pandoc_ast", version = "0.8", optional = true }
-pandoc = "0.8.0"
-structopt = "0.3"
-base64 = "0.13.0"
-roadmap = "0.3"
-tempfile = "3.1.0"
-tempfile-fast = "0.3.1"
+pikchr = "0.1"
+pulldown-cmark = "0.8.0"
regex = "1"
-serde_yaml = "0.8.11"
-serde_json = "1.0"
+roadmap = "0.3"
serde = { version = "1.0.101", features = ["derive"] }
serde-aux = "2.1"
-chrono = "0.4"
+serde_json = "1.0"
+serde_yaml = "0.8.11"
+structopt = "0.3"
+tempfile = "3.1.0"
+tempfile-fast = "0.3.1"
thiserror = "1"
-anyhow = "1"
-file_diff = "1"
-pikchr = "0.1"
-lazy_static = "1"
-git-testament = "0.2"
tracing = "0.1"
tracing-appender = "0.1"
tracing-subscriber = "0.2"
-pulldown-cmark = "0.8.0"
+time = { version = "0.3", features = ["formatting", "macros"] }
[dependencies.tera]
version = "1"