summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2023-04-05 19:06:43 +0300
committerLars Wirzenius <liw@liw.fi>2023-04-08 16:56:30 +0300
commitc8f96271fd18dd38c6112a01380a3246ee6b871a (patch)
tree4dd0a30c4eb098f43f69bcffc986dd77adf21d2b /Cargo.toml
parent014c3ff3d957a3012278e4f11a81404c873738e9 (diff)
downloadsubplot-c8f96271fd18dd38c6112a01380a3246ee6b871a.tar.gz
chore: drop Pandoc stuff as a Rust depenendency
Sponsored-by: author
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 2 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6aa3727..256fa47 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,11 +17,6 @@ default-run = "subplot"
[workspace]
members = ["subplotlib", "subplotlib-derive", "subplot-build", "examples/seq"]
-[features]
-default = ["ast_07"]
-ast_07 = ["pandoc_ast_07"]
-ast_08 = ["pandoc_ast_08"]
-
[dependencies]
anyhow = "1"
base64 = "0.13.0"
@@ -30,9 +25,6 @@ file_diff = "1"
git-testament = "0.2"
lazy_static = "1"
log = "0.4.16"
-pandoc = "0.8.0"
-pandoc_ast_07 = { package = "pandoc_ast", version = "0.7", optional = true }
-pandoc_ast_08 = { package = "pandoc_ast", version = "0.8", optional = true }
pikchr = "0.1"
pulldown-cmark = "0.9.0"
regex = "1"
@@ -46,6 +38,8 @@ tempfile-fast = "0.3.1"
thiserror = "1"
time = { version = "0.3", features = ["formatting", "macros"] }
env_logger = "0.9.0"
+html-escape = "0.2.13"
+line-col = "0.2.1"
[dependencies.tera]
version = "1"