summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2020-04-04 10:51:43 +0300
committerLars Wirzenius <liw@liw.fi>2020-04-11 19:43:42 +0300
commite6dd3c17b9ec3a24541a9d2f3ae7182170ac81f9 (patch)
tree19037245493dc3a8afaa4af361e69a4833e1cc26 /Cargo.toml
parent392ec661bc8db402d1efd2286962e692779c3429 (diff)
downloadsubplot-e6dd3c17b9ec3a24541a9d2f3ae7182170ac81f9.tar.gz
Change: docgen to not change output needlessly
If the output file wouldn't change, then don't update it. This is imperfect, since it still needs to produce the output file, so it can spend a bit of processing power to make no changes. But the alternative would be to make needless changes.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6ade64d..52e3f17 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -28,6 +28,7 @@ serde = { version = "1.0.101", features = ["derive"] }
chrono = "0.4"
thiserror = "1"
anyhow = "1"
+file_diff = "1"
[dependencies.tera]
version = "1"