summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2024-01-07 18:36:00 +0200
committerLars Wirzenius <liw@liw.fi>2024-01-07 19:28:18 +0200
commit9c77a3a520b6476324ad61bcbdbc9032278a1649 (patch)
treef0824c19b0e0f944c876ccfcab8d233f644fd613 /debian
parent3ba95d4135a87ef2827a1295cb95fc9039c7b0e5 (diff)
downloadsubplot-9c77a3a520b6476324ad61bcbdbc9032278a1649.tar.gz
build: allow building under Ambient
I'm about to start building a Subplot .deb under my new CI system, Ambient. Ambient runs builds without network access, so do "cargo install" with --offline. My Ambient setup runs ./check (also with --offline) as a separate step, so running it a second time in debian/rules seems wasteful, so disable that. Signed-off-by: Lars Wirzenius <liw@liw.fi> Sponsored-by: author
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 7360a53..ec7656c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,9 +7,9 @@ override_dh_auto_build:
true
override_dh_auto_install:
- cargo install --path=. --root=debian/subplot
+ cargo install --path=. --root=debian/subplot --offline
rm -f debian/subplot/.crates.toml
rm -f debian/subplot/.crates2.json
override_dh_auto_test:
- ./check
+ echo disabled: ./check