summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorDaniel Silverstone <dsilvers@digital-scurf.org>2021-11-19 19:32:42 +0000
committerDaniel Silverstone <dsilvers@digital-scurf.org>2021-11-19 20:18:49 +0000
commit572d3097770cd8e5cd22d7767c1d18e0d50b9a90 (patch)
treef0055968d40ea80fff10b52e1b4a9b58fa5d9a6e /flake.nix
parenta23d2dbc0b7a500e5e716037bc9acb5a96221410 (diff)
downloadsubplot-572d3097770cd8e5cd22d7767c1d18e0d50b9a90.tar.gz
flake.nix: Include black and flake8
Signed-off-by: Daniel Silverstone <dsilvers@digital-scurf.org>
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index c19f3bc..cdd50e6 100644
--- a/flake.nix
+++ b/flake.nix
@@ -12,8 +12,10 @@
let
pkgs = nixpkgs.legacyPackages.${system};
test-python-packages = python-packages:
- with python-packages;
- [ requests ];
+ with python-packages; [
+ requests
+ flake8
+ ];
in {
devShell = pkgs.mkShell {
@@ -26,6 +28,7 @@
daemonize
librsvg
(python3.withPackages test-python-packages)
+ black
];
shellHook = ''
export SUBPLOT_DOT_PATH=${pkgs.graphviz}/bin/dot