summaryrefslogtreecommitdiff
path: root/subplotlib/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Silverstone <dsilvers@digital-scurf.org>2021-06-12 15:14:03 +0100
committerDaniel Silverstone <dsilvers@digital-scurf.org>2021-06-12 15:14:03 +0100
commitc18796db698cb686a89c5dec049dd8c9896481ea (patch)
tree397a56b756a8c25e4903f3329730deba6d0947c4 /subplotlib/Cargo.toml
parent56ad5f7ba657a1cb70d5d74da6514582df18c62e (diff)
downloadsubplot-c18796db698cb686a89c5dec049dd8c9896481ea.tar.gz
chore: update Cargo.tomls for release
Signed-off-by: Daniel Silverstone <dsilvers@digital-scurf.org>
Diffstat (limited to 'subplotlib/Cargo.toml')
-rw-r--r--subplotlib/Cargo.toml13
1 files changed, 11 insertions, 2 deletions
diff --git a/subplotlib/Cargo.toml b/subplotlib/Cargo.toml
index a9e8f85..07e00c1 100644
--- a/subplotlib/Cargo.toml
+++ b/subplotlib/Cargo.toml
@@ -1,8 +1,17 @@
[package]
name = "subplotlib"
version = "0.1.0"
-authors = ["Daniel Silverstone <dsilvers@digital-scurf.org>"]
+authors = [
+ "Lars Wirzenius <liw@liw.fi>",
+ "Daniel Silverstone <dsilvers@digital-scurf.org>",
+]
edition = "2018"
+license = "GPL-3.0-or-later"
+description = '''
+Utility functions and types for `subplot codegen` generated Rust based
+test suites. Relies on `subplotlib-derive` for associated macros.'''
+homepage = "https://subplot.liw.fi/"
+repository = "https://gitlab.com/subplot/subplot"
[dependencies]
@@ -18,4 +27,4 @@ filetime = "0.2"
regex = "1.4"
shell-words = "1.0"
unescape = "0.1"
-remove_dir_all = "0.6"
+remove_dir_all = "0.7"