summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml25
1 files changed, 10 insertions, 15 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6aa3727..658733e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,11 +1,11 @@
[package]
name = "subplot"
-version = "0.6.0"
+version = "0.9.0"
authors = [
"Lars Wirzenius <liw@liw.fi>",
"Daniel Silverstone <dsilvers@digital-scurf.org>",
]
-edition = "2018"
+edition = "2021"
license = "MIT-0"
description = '''
tools for specifying, documenting,
@@ -13,42 +13,37 @@ and implementing automated acceptance tests for systems and software'''
homepage = "https://subplot.tech/"
repository = "https://gitlab.com/subplot/subplot"
default-run = "subplot"
+rust-version = "1.70"
[workspace]
members = ["subplotlib", "subplotlib-derive", "subplot-build", "examples/seq"]
-[features]
-default = ["ast_07"]
-ast_07 = ["pandoc_ast_07"]
-ast_08 = ["pandoc_ast_08"]
-
[dependencies]
anyhow = "1"
-base64 = "0.13.0"
+base64 = "0.21.0"
clap = { version = "4", features = ["derive", "env", "string"] }
file_diff = "1"
git-testament = "0.2"
lazy_static = "1"
log = "0.4.16"
-pandoc = "0.8.0"
-pandoc_ast_07 = { package = "pandoc_ast", version = "0.7", optional = true }
-pandoc_ast_08 = { package = "pandoc_ast", version = "0.8", optional = true }
pikchr = "0.1"
pulldown-cmark = "0.9.0"
regex = "1"
-roadmap = "0.4.5"
+roadmap = "0.5.0"
serde = { version = "1.0.101", features = ["derive"] }
serde-aux = { version = "4.0", default-features = false }
serde_json = "1.0"
-serde_yaml = "0.8.26"
+serde_yaml = "0.9.21"
tempfile = "3.1.0"
tempfile-fast = "0.3.1"
thiserror = "1"
time = { version = "0.3", features = ["formatting", "macros"] }
-env_logger = "0.9.0"
+env_logger = "0.10.0"
+html-escape = "0.2.13"
+line-col = "0.2.1"
[dependencies.tera]
-version = "1"
+version = "1.18"
default-features = false
# Expand out tera's default featurs, except for chrono related ones
features = ["slug", "percent-encoding", "humansize", "rand"]