summaryrefslogtreecommitdiff
path: root/subplotlib-derive/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'subplotlib-derive/Cargo.toml')
-rw-r--r--subplotlib-derive/Cargo.toml9
1 files changed, 5 insertions, 4 deletions
diff --git a/subplotlib-derive/Cargo.toml b/subplotlib-derive/Cargo.toml
index 36337d4..7d5b0c4 100644
--- a/subplotlib-derive/Cargo.toml
+++ b/subplotlib-derive/Cargo.toml
@@ -1,23 +1,24 @@
[package]
name = "subplotlib-derive"
-version = "0.6.0"
+version = "0.9.0"
authors = [
"Lars Wirzenius <liw@liw.fi>",
"Daniel Silverstone <dsilvers@digital-scurf.org>",
]
-edition = "2018"
+edition = "2021"
license = "MIT-0"
description = '''
macros for constructing subplotlib based test suites, typically
generated by `subplot codegen`.'''
homepage = "https://subplot.tech/"
repository = "https://gitlab.com/subplot/subplot"
+rust-version = "1.70"
[lib]
proc-macro = true
[dependencies]
-syn = { version = "1", features = ["full"] }
+syn = { version = "2", features = ["full"] }
quote = "1"
proc-macro2 = "1"
-fehler = "1"
+culpa = "1.0.1"