summaryrefslogtreecommitdiff
path: root/subplotlib/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'subplotlib/Cargo.toml')
-rw-r--r--subplotlib/Cargo.toml15
1 files changed, 8 insertions, 7 deletions
diff --git a/subplotlib/Cargo.toml b/subplotlib/Cargo.toml
index c347886..bb328c6 100644
--- a/subplotlib/Cargo.toml
+++ b/subplotlib/Cargo.toml
@@ -1,24 +1,24 @@
[package]
name = "subplotlib"
-version = "0.6.0"
+version = "0.9.0"
authors = [
"Lars Wirzenius <liw@liw.fi>",
"Daniel Silverstone <dsilvers@digital-scurf.org>",
]
-edition = "2018"
+edition = "2021"
license = "MIT-0"
description = '''
Utility functions and types for `subplot codegen` generated Rust based
test suites. Relies on `subplotlib-derive` for associated macros.'''
homepage = "https://subplot.tech/"
repository = "https://gitlab.com/subplot/subplot"
+rust-version = "1.70"
[dependencies]
-fehler = "1"
-subplotlib-derive = { version = "0.6.0", path = "../subplotlib-derive" }
+subplotlib-derive = { version = "0.9.0", path = "../subplotlib-derive" }
lazy_static = "1"
-base64 = "0.13"
+base64 = "0.21.0"
state = "0.5"
tempfile = "3.1"
fs2 = "0.4"
@@ -27,12 +27,13 @@ filetime = "0.2"
regex = "1.4"
shell-words = "1.0"
unescape = "0.1"
-remove_dir_all = "0.7"
+remove_dir_all = "0.8"
+culpa = "1.0.1"
[build-dependencies]
glob = "0.3"
-subplot-build = { version = "0.6.0", path = "../subplot-build" }
+subplot-build = { version = "0.9.0", path = "../subplot-build" }
[dev-dependencies]
serde_json = "1.0"