summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2021-04-23 08:01:02 +0300
committerLars Wirzenius <liw@liw.fi>2021-04-28 11:31:40 +0300
commitfe5b650897f6715d40a29e72d821caf812f9edaa (patch)
tree44757e6c3139948b1738195a15eabf4f5c7ca828 /Cargo.toml
parenta21cd46fc76ca7cb1c87a218c7c561d668a64125 (diff)
downloadsummain-rs-fe5b650897f6715d40a29e72d821caf812f9edaa.tar.gz
refactor: use async for concurrency
Normal tokio async tasks for collecting metadata, blocking tasks for computing checksums, so that all available CPU can be used for that.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e0403c4..444263f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,8 +13,10 @@ edition = "2018"
[dependencies]
anyhow = "1"
digest = "0.9"
+num_cpus = "1"
serde = { version = "1", features = ["derive"] }
serde_yaml = "0.8"
sha2 = "0.9"
structopt = "0.3"
+tokio = { version = "1", features = ["full"] }
unix_mode = "0.1"