summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2011-02-13 09:55:32 +0000
committerLars Wirzenius <liw@liw.fi>2011-02-13 09:55:32 +0000
commit1ea6e55f40a0ee8afe8eb15a17a2be8e3fbf8742 (patch)
treea1689c712961321d786983bf75d97c7f69c0b8fe /debian
parente6357e4ee0d95eac3973452723010017eacf04a4 (diff)
downloadsummain-1ea6e55f40a0ee8afe8eb15a17a2be8e3fbf8742.tar.gz
* debian/rules: Verify that versions match between debian/changelog and
setup.py. * debian/control: Add build-dependency on extrautils, required for the version matching checking.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog9
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules7
3 files changed, 17 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 673d3d9..8e77525 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+summain (0.2) squeeze; urgency=low
+
+ * debian/rules: Verify that versions match between debian/changelog and
+ setup.py.
+ * debian/control: Add build-dependency on extrautils, required for
+ the version matching checking.
+
+ -- Lars Wirzenius <liw@liw.fi> Sun, 13 Feb 2011 09:47:52 +0000
+
summain (0.1) squeeze; urgency=low
* Upload to squeeze.
diff --git a/debian/control b/debian/control
index d0085f0..890130f 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,8 @@ Maintainer: Lars Wirzenius <liw@liw.fi>
Section: misc
Priority: optional
Standards-Version: 3.8.3
-Build-Depends: debhelper (>= 7.3.8), python-support (>= 1.0.3), python (>= 2.5)
+Build-Depends: debhelper (>= 7.3.8), python-support (>= 1.0.3),
+ python (>= 2.5), extrautils
Package: summain
Architecture: all
diff --git a/debian/rules b/debian/rules
index cbe925d..5b114f1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,3 +1,8 @@
#!/usr/bin/make -f
%:
- dh $@
+ dh $@ --with-buildsystem=python_distutils
+
+override_dh_auto_build:
+ dh_auto_build $@ --with-buildsystem=python_distutils
+ setuppy-debian-versions-match
+