summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2011-07-24 11:32:26 +0100
committerLars Wirzenius <liw@liw.fi>2011-07-24 11:32:26 +0100
commit64f314d860c9928bfa817422ca4e0482350e6a51 (patch)
treebe6c4f12a15ca2b3fc0cc085e0feaa5f7bfec1a1 /debian
parenta0f09cb89f7b1cb482880c91044e08bf06f396c5 (diff)
downloadsummain-64f314d860c9928bfa817422ca4e0482350e6a51.tar.gz
debian/rules, debian/control: Fixed for dh_python2 and Debian.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/control5
-rwxr-xr-xdebian/rules14
3 files changed, 11 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 75a7f33..a8b4a14 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ summain (0.9-1) unstable; urgency=low
* New upstream release. This is the first release to be uploaded to
Debian. (Closes: #631861)
* debian/source/format: Use 3.0 (quilt).
+ * debian/rules, debian/control: Fixed for dh_python2 and Debian.
-- Lars Wirzenius <liw@liw.fi> Mon, 27 Jun 2011 23:03:59 +0100
diff --git a/debian/control b/debian/control
index b3659af..48b8443 100644
--- a/debian/control
+++ b/debian/control
@@ -3,15 +3,14 @@ Maintainer: Lars Wirzenius <liw@liw.fi>
Section: misc
Priority: optional
Standards-Version: 3.9.2
-Build-Depends: debhelper (>= 7.3.8), python-all (>= 2.6.6-3~), extrautils,
+Build-Depends: debhelper (>= 7.3.8), python-all (>= 2.6.6-3~),
python-cliapp (>= 0.7)
Homepage: http://liw.fi/summain/
X-Python-Version: >= 2.6
Package: summain
Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}, python (>= 2.6),
- python-cliapp (>= 0.7)
+Depends: ${python:Depends}, ${misc:Depends}, python-cliapp (>= 0.7)
Description: create file manifests with checksums
Summain generates file manifests, which contain metadata about the files,
and a checksum of their content for regular files. The manifest can be
diff --git a/debian/rules b/debian/rules
index c15d590..96d6cd4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,11 +1,13 @@
#!/usr/bin/make -f
+
%:
- dh $@ --with python2
+ dh $@ --with=python2 --buildsystem=python_distutils
override_dh_auto_build:
- dh_auto_build $@ --with-buildsystem=python_distutils
- setuppy-debian-versions-match
-
-override_dh_auto_install:
- python setup.py install --prefix=debian/summain/usr
+ $(MAKE)
+ dh_auto_build --with=python2 --buildsystem=python_distutils
+
+override_dh_auto_clean:
+ $(MAKE) clean
+ dh_auto_clean --with=python2 --buildsystem=python_distutils