summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2010-06-06 15:18:46 +1200
committerLars Wirzenius <liw@liw.fi>2010-06-06 15:18:46 +1200
commit760f14510663a9910c656c8b9232731645206369 (patch)
treecd4fc62ac39c5466e9c476a9775d8ce0c8c5e6a2 /setup.py
parent7a45765652ee173c1a0b8607c35250bc0684edf1 (diff)
downloadttystatus-760f14510663a9910c656c8b9232731645206369.tar.gz
Add Debian packaging.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..155a050
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,29 @@
+# Copyright 2010 Lars Wirzenius
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+
+from distutils.core import setup
+
+import ttystatus
+
+setup(
+ name='ttystatus',
+ version=ttystatus.version,
+ description='terminal progress bar and status output for command line',
+ author='Lars Wirzenius',
+ author_email='liw@liw.fi',
+# url='http://liw.fi/ttystatus/',
+ packages=['ttystatus'],
+)