summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2013-06-09 11:30:20 +0100
committerLars Wirzenius <liw@liw.fi>2013-06-09 11:30:20 +0100
commit63fac3e9f7913865de440e7c02804ddbc2d460a5 (patch)
tree1d54efcea574645fd92b750667322d983f702c72 /setup.py
parent7405dace9c241c2c75f06436effd20813b45ed4a (diff)
downloadcmdtest-63fac3e9f7913865de440e7c02804ddbc2d460a5.tar.gz
Run coverage test runner with exclusions
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 108841a..d42add3 100644
--- a/setup.py
+++ b/setup.py
@@ -59,7 +59,9 @@ class Check(Command):
pass
def run(self):
- subprocess.check_call(['python', '-m', 'CoverageTestRunner'])
+ subprocess.check_call(
+ ['python', '-m', 'CoverageTestRunner',
+ '--ignore-missing-from', 'without-tests'])
os.remove('.coverage')
subprocess.check_call(['./cmdtest', 'echo-tests'])