summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 108841a..d42add3 100644
--- a/setup.py
+++ b/setup.py
@@ -59,7 +59,9 @@ class Check(Command):
pass
def run(self):
- subprocess.check_call(['python', '-m', 'CoverageTestRunner'])
+ subprocess.check_call(
+ ['python', '-m', 'CoverageTestRunner',
+ '--ignore-missing-from', 'without-tests'])
os.remove('.coverage')
subprocess.check_call(['./cmdtest', 'echo-tests'])