summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2011-12-25 18:36:31 +0000
committerLars Wirzenius <liw@liw.fi>2011-12-25 18:36:31 +0000
commitdfb852d22efc08e67568e4088da498a49251a7bb (patch)
tree2398351b43462ccec3fceec169dc96052fd58ed8 /setup.py
parent2db25163747d80e30a255b230ba5986c50b53d91 (diff)
downloadcmdtest-dfb852d22efc08e67568e4088da498a49251a7bb.tar.gz
have setup.py run echo-tests and sort-tests
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9bd2a82..2d10bcd 100644
--- a/setup.py
+++ b/setup.py
@@ -61,6 +61,9 @@ class Check(Command):
def run(self):
subprocess.check_call(['python', '-m', 'CoverageTestRunner'])
os.remove('.coverage')
+
+ subprocess.check_call(['./cmdtest', 'echo-tests'])
+ subprocess.check_call(['./cmdtest', 'sort-tests'])
setup(name='cmdtest',