summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2017-04-07 15:15:23 +0300
committerLars Wirzenius <liw@liw.fi>2017-04-07 15:15:23 +0300
commit9a6dd537c7baeb3f62f26b974f9dcdf9010cb5e2 (patch)
tree42ca333443ee477c56a10dae460ace18105dcc5b /setup.py
parent6b7f99939141afebbc88f5ec68a083fda738da4b (diff)
downloaddistix-9a6dd537c7baeb3f62f26b974f9dcdf9010cb5e2.tar.gz
Move check -running from setup.py to shell script
This lets me add optional args to yarn more easily.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index cc0a3b0..d091592 100644
--- a/setup.py
+++ b/setup.py
@@ -80,7 +80,9 @@ class Check(Command):
def run_yarns(self):
cliapp.runcmd(
- ['yarn'] + glob.glob('yarns/*.yarn'),
+ ['yarn', '--shell=python2', '--shell-arg', '',
+ '--shell-library=yarns/lib.py', '--cd-datadir'] +
+ glob.glob('yarns/*.yarn'),
stdout=None, stderr=None)
def command_is_available(self, command_name):