summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorIvan Dolgov <ivan@dolgov.fi>2019-03-16 15:14:18 +0200
committerIvan Dolgov <ivan@dolgov.fi>2019-03-16 15:33:28 +0200
commit227c1ae67bb80a5e9b9036a9bdb9f11be073669f (patch)
tree66ed50756e86a265c8bf08d0493bcc466c83d026 /setup.py
parent01bdba935a667e8c1606d6d040086488c82b0e38 (diff)
downloadickapi-227c1ae67bb80a5e9b9036a9bdb9f11be073669f.tar.gz
Initial setupivan/initial
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py45
1 files changed, 45 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..30bf11c
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,45 @@
+#!/usr/bin/python3
+
+import setuptools
+
+
+with open('ickapi/version.py', 'r') as f:
+ exec(f.read())
+
+with open('README', 'r') as f:
+ long_description = f.read()
+
+setuptools.setup(
+ name='ickapi',
+ version=__version__,
+ description='Ick API, a RESTful HTTP API/facade for Ick CI frontends',
+ long_description=long_description,
+ long_description_content_type='text/markdown',
+ url='http://git.liw.fi/ickapi/',
+ author='Ivan Dolgov',
+ author_email='ivan@dolgov.fi',
+ license='GPLv3+',
+ packages=setuptools.find_packages(exclude=['tests']),
+ python_requires='>=3.6',
+ install_requires=[
+ 'aiohttp',
+ 'gunicorn',
+ ],
+ extras_require={
+ 'tests': [
+ 'pycodestyle',
+ 'pydocstyle',
+ 'pylint',
+ 'pytest',
+ ]
+ },
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'License :: OSI Approved :: '
+ + 'GNU General Public License v3 or later (GPLv3+)',
+ 'Environment :: Web Environment',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.6',
+ 'Operating System :: POSIX :: Linux',
+ ],
+)