summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py45
1 files changed, 45 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..30bf11c
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,45 @@
+#!/usr/bin/python3
+
+import setuptools
+
+
+with open('ickapi/version.py', 'r') as f:
+ exec(f.read())
+
+with open('README', 'r') as f:
+ long_description = f.read()
+
+setuptools.setup(
+ name='ickapi',
+ version=__version__,
+ description='Ick API, a RESTful HTTP API/facade for Ick CI frontends',
+ long_description=long_description,
+ long_description_content_type='text/markdown',
+ url='http://git.liw.fi/ickapi/',
+ author='Ivan Dolgov',
+ author_email='ivan@dolgov.fi',
+ license='GPLv3+',
+ packages=setuptools.find_packages(exclude=['tests']),
+ python_requires='>=3.6',
+ install_requires=[
+ 'aiohttp',
+ 'gunicorn',
+ ],
+ extras_require={
+ 'tests': [
+ 'pycodestyle',
+ 'pydocstyle',
+ 'pylint',
+ 'pytest',
+ ]
+ },
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'License :: OSI Approved :: '
+ + 'GNU General Public License v3 or later (GPLv3+)',
+ 'Environment :: Web Environment',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.6',
+ 'Operating System :: POSIX :: Linux',
+ ],
+)