summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLars Wirzenius <liw@localhost>2014-06-03 13:09:32 +0000
committerLars Wirzenius <liw@localhost>2014-06-03 13:09:32 +0000
commit315db640f463613cae4de4c02cc52d2be6d5684a (patch)
tree3a922456821d1882c778267f04bbf0c4d0bfca68 /Makefile.am
downloadsoundconverter-debian-packaging-master.tar.gz
Initial import for soundconverter 2.1.3HEADmaster
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..ffc8f66
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,21 @@
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = dist-xz no-dist-gzip
+
+SUBDIRS = bin soundconverter data doc po
+
+CLEANFILES=
+
+EXTRA_DIST = autogen.sh
+DISTCLEANFILES = intltool-extract.in intltool-merge.in intltool-update.in intltool-extract intltool-merge intltool-update
+
+
+release: changelog dist
+ echo git tag -a $(VERSION) -m release-$(VERSION)
+ echo git push --tags
+ echo lp-project-upload soundconverter $(VERSION) soundconverter-$(VERSION).tar.xz
+
+# generate the changelog from git log
+changelog:
+ git log 3fd8.. --pretty --numstat --summary | ./git2cl.pl > ChangeLog
+ cat ChangeLog.old >> ChangeLog