summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..ffc8f66
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,21 @@
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = dist-xz no-dist-gzip
+
+SUBDIRS = bin soundconverter data doc po
+
+CLEANFILES=
+
+EXTRA_DIST = autogen.sh
+DISTCLEANFILES = intltool-extract.in intltool-merge.in intltool-update.in intltool-extract intltool-merge intltool-update
+
+
+release: changelog dist
+ echo git tag -a $(VERSION) -m release-$(VERSION)
+ echo git push --tags
+ echo lp-project-upload soundconverter $(VERSION) soundconverter-$(VERSION).tar.xz
+
+# generate the changelog from git log
+changelog:
+ git log 3fd8.. --pretty --numstat --summary | ./git2cl.pl > ChangeLog
+ cat ChangeLog.old >> ChangeLog