summaryrefslogtreecommitdiff
path: root/subplotlib/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2021-11-27 09:17:58 +0200
committerLars Wirzenius <liw@liw.fi>2021-11-27 14:10:35 +0200
commit99c0d2c80a476e13866cbd74b6e35ff95a1e5d58 (patch)
tree62249bc5c5a3b6a47bffc723dc21849f8f83689f /subplotlib/Cargo.toml
parente3a8468282771369b5fb37be5c6e23c1e2833433 (diff)
downloadsubplot-99c0d2c80a476e13866cbd74b6e35ff95a1e5d58.tar.gz
refactor: use build.rs for testing subplotlib subplots
A bit of dog-fooding: use subplot-build to test subplotlib. Add a subplotlib/build.rs script to generate test code in Rust for the subplotlib/*.md subplots. The generated code is included in tests/*.rs, and run with "cargo test". Drop the same functionality from the ./check script.. Sponsored-by: author
Diffstat (limited to 'subplotlib/Cargo.toml')
-rw-r--r--subplotlib/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/subplotlib/Cargo.toml b/subplotlib/Cargo.toml
index 465f0de..781a017 100644
--- a/subplotlib/Cargo.toml
+++ b/subplotlib/Cargo.toml
@@ -28,3 +28,8 @@ regex = "1.4"
shell-words = "1.0"
unescape = "0.1"
remove_dir_all = "0.7"
+
+
+[build-dependencies]
+glob = "0.3"
+subplot-build = { version="0.1", path = "../subplot-build" }