summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2011-02-13 09:55:32 +0000
committerLars Wirzenius <liw@liw.fi>2011-02-13 09:55:32 +0000
commit1ea6e55f40a0ee8afe8eb15a17a2be8e3fbf8742 (patch)
treea1689c712961321d786983bf75d97c7f69c0b8fe /debian/rules
parente6357e4ee0d95eac3973452723010017eacf04a4 (diff)
downloadsummain-1ea6e55f40a0ee8afe8eb15a17a2be8e3fbf8742.tar.gz
* debian/rules: Verify that versions match between debian/changelog and
setup.py. * debian/control: Add build-dependency on extrautils, required for the version matching checking.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index cbe925d..5b114f1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,3 +1,8 @@
#!/usr/bin/make -f
%:
- dh $@
+ dh $@ --with-buildsystem=python_distutils
+
+override_dh_auto_build:
+ dh_auto_build $@ --with-buildsystem=python_distutils
+ setuppy-debian-versions-match
+