summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2023-09-08 17:47:14 +0300
committerLars Wirzenius <liw@liw.fi>2023-09-08 17:47:14 +0300
commit2654c57e25218247abbec6864b857d1d95493cac (patch)
tree09c608ef68974a55984e52ab316e8428f864e4dd /Cargo.toml
parent1be7278231da7274b03cd4456f9a806ca098d8aa (diff)
downloadvmadm-2654c57e25218247abbec6864b857d1d95493cac.tar.gz
refactor: use current clap instead of structopt for command line
Sponsored-by: author
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index bea87a3..0f7dcb5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,6 +13,7 @@ repository = "https://gitlab.com/larswirzenius/vmadm"
[dependencies]
anyhow = "1"
bytesize = "1"
+clap = { version = "4.4.2", features = ["derive"] }
directories-next = "2"
home-dir = "0.1.0"
lazy_static = "1.4.0"
@@ -23,7 +24,6 @@ serde = { version = "1", features = ["derive"] }
serde_json = "1.0.64"
serde_yaml = "0.8"
shell-words = "1"
-structopt = "0.3"
tempfile = "3.2"
thiserror = "1"
virt = "0.2.12"