summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Silverstone <dsilvers+gitlab@digital-scurf.org>2021-04-08 09:03:50 +0000
committerDaniel Silverstone <dsilvers+gitlab@digital-scurf.org>2021-04-08 09:03:50 +0000
commit924fc1add2de3edac4ad4b1097a3bbbb73d0ad50 (patch)
treee5c9689e1ff60953502faf55eacb8a82c2726b8a /Cargo.toml
parent518e7dc2d5f97387702af0a300cc2842bd0deec6 (diff)
parent0b0cc421e79bff9f8692e8c771c5e72ee4414032 (diff)
downloadjt2-924fc1add2de3edac4ad4b1097a3bbbb73d0ad50.tar.gz
Merge branch 'tera' into 'main'
feat! add support for tera templates for new journal entries Closes #8 and #10 See merge request larswirzenius/jt!11
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 7 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a76755a..6bbe649 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,13 +5,14 @@ authors = ["Lars Wirzenius <liw@liw.fi>"]
edition = "2018"
[dependencies]
-structopt = "0.3"
anyhow = "1"
-thiserror = "1"
-pretty_env_logger = "0.4"
-log = "0.4"
+chrono = "0.4"
directories-next = "2.0.0"
+log = "0.4"
+pretty_env_logger = "0.4"
+regex = "1"
serde = { version = "1", features = ["derive"] }
serde_yaml = "0.8"
-regex = "1"
-chrono = "0.4"
+structopt = "0.3"
+tera = { version = "1", default-features = false }
+thiserror = "1"