summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorLars Wirzenius <liw@liw.fi>2024-02-24 10:45:35 +0200
committerLars Wirzenius <liw@liw.fi>2024-02-25 14:58:54 +0200
commit7b58008d81e6433b088b9a926bedb1ee28c32e9f (patch)
tree2bb7ddf47afa246b2c5bbded3e476b253ec043b1 /debian
parentf7b948a1f9535a4e266314822aa98cdd506b8d15 (diff)
downloadsubplot-7b58008d81e6433b088b9a926bedb1ee28c32e9f.tar.gz
build: drop build-dep on unused dh-cargo; install lintian
Drop dh-cargo as we don't need to build a deb. Install the lintian files in the binary so that lintian will actually find them. Normally, dh will do this automatically, but we override the installation step so we have to do it ourselves. Signed-off-by: Lars Wirzenius <liw@liw.fi> Sponsored-by: author
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules3
2 files changed, 3 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 22409e4..fb9fd6a 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Maintainer: Lars Wirzenius <liw@liw.fi>
Section: utils
Priority: optional
Standards-Version: 4.2.0
-Build-Depends: debhelper (>= 10~), dh-cargo, python3, python3-requests,
+Build-Depends: debhelper (>= 10~), python3, python3-requests,
librsvg2-bin, graphviz, plantuml, daemonize, procps, tidy
Homepage: https://subplot.liw.fi
diff --git a/debian/rules b/debian/rules
index ec7656c..f1632f8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,7 @@
#!/usr/bin/make -f
%:
- dh $@ --buildsystem cargo
+ dh $@
override_dh_auto_build:
true
@@ -10,6 +10,7 @@ override_dh_auto_install:
cargo install --path=. --root=debian/subplot --offline
rm -f debian/subplot/.crates.toml
rm -f debian/subplot/.crates2.json
+ dh_lintian
override_dh_auto_test:
echo disabled: ./check