summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules3
2 files changed, 3 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 22409e4..fb9fd6a 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Maintainer: Lars Wirzenius <liw@liw.fi>
Section: utils
Priority: optional
Standards-Version: 4.2.0
-Build-Depends: debhelper (>= 10~), dh-cargo, python3, python3-requests,
+Build-Depends: debhelper (>= 10~), python3, python3-requests,
librsvg2-bin, graphviz, plantuml, daemonize, procps, tidy
Homepage: https://subplot.liw.fi
diff --git a/debian/rules b/debian/rules
index ec7656c..f1632f8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,7 @@
#!/usr/bin/make -f
%:
- dh $@ --buildsystem cargo
+ dh $@
override_dh_auto_build:
true
@@ -10,6 +10,7 @@ override_dh_auto_install:
cargo install --path=. --root=debian/subplot --offline
rm -f debian/subplot/.crates.toml
rm -f debian/subplot/.crates2.json
+ dh_lintian
override_dh_auto_test:
echo disabled: ./check